Brian F爱
从专注于角图,Web技术以yobet英雄联盟及波特兰的Node.js的Google开发人员专家中学习。
广告 ·ultimatecourses.com.
用终极课程学习角度正确的方式

wordpress插件使用https

这篇文章主要集中在使用旧的WordPress插件的那些(并且可能不应再使用),并且在尝试通过HTTPS将WordPress博客加载SSL上的WordPress博客时会导致问题。这是会发生什么:浏览器是针对的https://yourblog.com.并且您注意到您的一个插件不起作用。如果您查看JavaScript控制台,您将看到这样的错误:

页面'https://yourblog.com.'加载了HTTPS,但从'中运行不安全的内容'http://yourblog.com/wp-content/plugins/bad-plugin/required-asset.js.'

此处的问题是,在指定时,该插件不会使用正确的URL必修asset.js.(或任何文件在您的情况下)文件路径。修复它很容易。调查插件代码后,我注意到它正在使用已弃用的常量wp_plugin_url.

以下是已弃用的代码:

界定'playerss_url'wp_plugin_url.'/'plugin_baseName.妄想__文件__;

这是更新的代码:

界定'playerss_url'plugins_url.'/'__文件__;

既然插件不再使用已弃用的常量,插件在使用HTTPS请求页面时,请通过HTTPS正确加载JavaScript。

Brian F爱

嗨,我是布莱恩。我对类型名称,Angular和node.js感兴趣我嫁给了我最好的朋友邦妮,我住在波特兰和我滑雪(很多)。